Word Amalgamation源程序

类别:编程语言 点击:0 评论:0 推荐:
In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words.


Input

The input contains four parts:

1. a dictionary, which consists of at least one and at most 100 words, one per line;
2. a line containing XXXXXX, which signals the end of the dictionary;
3. one or more scrambled `words' that you must unscramble, each on a line by itself; and
4. another line containing XXXXXX, which signals the end of the file.

All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique.


Output

For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line ``NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.

Sample Input

tarp
given
score
refund
only
trap
work
earn
course
pepper
part
XXXXXX
resco
nfudre
aptr
sett
oresuc
XXXXXX


Sample Output

score
******
refund
******
part
tarp
trap
******
NOT A VALID WORD
******
course
******

我的源程序如下:

#include <string>
#include <iostream>
#include <vector>

using namespace std;

void SelectionSort(vector<string>& s){
 string temp;
 int min;
 for(unsigned int i=0;i<s.size();i++){
  min=i;
  for(unsigned int j=i+1;j<s.size();j++)
   if(s[min]>s[j]) min=j;
  temp=s[min];
  s[min]=s[i];
  s[i]=temp;
 }
}

void main(){
 vector<string> dic;
 vector<string> scramble;
 vector<string> display;
 string line;
 while(getline(cin,line)){
  if(line=="XXXXXX") break;
  dic.push_back(line);
 }
 while(getline(cin,line)){
  if(line=="XXXXXX") break;
  scramble.push_back(line);
 }
 
 bool found;
 for(unsigned int i=0;i<scramble.size();i++){
  found=false;
     display.clear();
  for(unsigned int j=0;j<dic.size();j++){
   if(scramble[i].length()!=dic[j].length())
    continue; 
   
   unsigned int count=0;
   int pos;
   string temp=scramble[i];
   for(unsigned int k=0;k<dic[j].length();k++){
    pos=temp.find(dic[j][k]);
    if(pos!=string::npos) {
     temp.erase(pos,1);  //此处是关键,花费了我好长时间,必须把比较过的删除掉,否则无法确定两个单词有相同的字母。
     count++;
    }
   
   }
   if(count==dic[j].length()){
        found=true;
    display.push_back(dic[j]);
    
   }

  }
  if(!found)
   cout<<"NOT A VALID WORD"<<endl;
  else{
    SelectionSort(display);
    for(unsigned int k=0;k<display.size();k++)
    cout<<display[k]<<endl;
        }
  cout<<"******"<<endl;
 }
 
}

本文地址:http://com.8s8s.com/it/it22083.htm