浙大在线评测 1109 Language of FatMouse

类别:编程语言 点击:0 评论:0 推荐:

Problem:

    We all know that FatMouse doesn't speak English. But now he has to be prepared since our nation will join WTO soon. Thanks to Turing we have computers to help him.


Input:

    Input consists of up to 100,005 dictionary entries, followed by a blank line, followed by a message of up to 100,005 words. Each dictionary entry is a line containing an English word, followed by a space and a FatMouse word. No FatMouse word appears more than once in the dictionary. The message is a sequence of words in the language of FatMouse, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.


Output:

    Output is the message translated to English, one word per line. FatMouse words not in the dictionary should be translated as "eh".


Sample Input:

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay


Sample Output:

cat
eh
loops


Solution:

#include <iostream>
#include <string>
#include <map>
using namespace std;

// 声明:本代码仅供学习之用,请不要作为个人的成绩提交。
// http://blog.csdn.net/mskia
// email: [email protected]

int main( void ) {

    map< string , string > dic;
    map< string , string >::iterator p;
   
    string eword , mword;
    while ( cin >> eword ) {
        int len = eword.size( );
        if ( eword[ len - 2 ] == 'a' && eword[ len - 1 ] == 'y' ) {
            break;
        }
       
        cin >> mword;
        dic.insert( pair< string , string >( mword , eword ) );
    }
   
    mword = eword;
    do {
        p = dic.find( mword );
        if ( p == dic.end( ) ) {
            cout << "eh" << endl;
        } else {
            cout << p->second << endl;
        }
    } while ( cin >> mword );


    return 0;
}

本文地址:http://com.8s8s.com/it/it26765.htm