浙大在线评测 1088 System Overload

类别:编程语言 点击:0 评论:0 推荐:

Problem:

    Recently you must have experienced that when too many people use the BBS simultaneously, the net becomes very, very slow.

    To put an end to this problem, the Sysop has developed a contingency scheme for times of peak load to cut off net access for some buildings of the university in a systematic, totally fair manner. Our university buildings were enumerated randomly from 1 to n. XWB is number 1, CaoGuangBiao (CGB) Building is number 2, and so on in a purely random order.
Then a number m would be picked at random, and BBS access would first be cut off in building 1 (clearly the fairest starting point) and then in every mth building after that, wrapping around to 1 after n, and ignoring buildings already cut off. For example, if n=17 and m=5, net access would be cut off to the buildings in the order [1,6,11,16,5,12,2,9,17,10,4,15,14,3,8,13,7]. The problem is that it is clearly fairest to cut off CGB Building last (after all, this is where the best programmers come from), so for a given n, the random number m needs to be carefully chosen so that building 2 is the last building selected.

    Your job is to write a program that will read in a number of buildings n and then determine the smallest integer m that will ensure that our CGB Building can surf the net while the rest of the university is cut off.


Input:

    The input file will contain one or more lines, each line containing one integer n with 3 <= n < 150, representing the number of buildings in the university.
    Input is terminated by a value of zero (0) for n.


Output:

    For each line of the input, print one line containing the integer m fulfilling the requirement specified above.


Sample Input:

3
4
5
6
7
8
9
10
11
12
0


Sample Output:

2
5
2
4
3
11
2
3
8
16


Solution:

// 声明:本代码仅供学习之用,请不要作为个人的成绩提交。
// http://blog.csdn.net/mskia
// email: [email protected]

#include <iostream>

using namespace std;

int main( void ) {
    int n;
    while ( cin >> n && n != 0 ) {
        int m;
        int successM = 0;
        int maintain = n - 1;
        int j = 0;

        for ( m = 2; m < 1000; ++m ) {
            int *result = new int [ n ];
            for ( int i = 0; i < n; ++i ) {
                result[ i ] = i;
            }
            
            j = 0;
            int step = m - 1;
            while ( maintain != 0 ) {
                if ( result[1] == 0 ) {
                    break;
                }

                if ( maintain == 1 && result[ 1 ] != 0 ) {
                    successM = m;
                    break;
                } 

                if ( j >= n ) {
                    j = 0;
                }
   
                if ( result[ j ] != 0 && step != 0 ) {
                    ++j;
                    --step;
                } else if ( result[ j ] != 0 && step == 0 ) {
                    result[ j ] = 0;
                    step = m - 1;
                    --maintain;
                    ++j;
                } else if ( result[ j ] == 0 ) {
                    ++j;
                }   
            }
            
            if ( maintain == 0 ) {
                successM = m;
                break;
            }

            if ( successM != 0 ) {
                break;
            }
            
            maintain = n - 1;
            delete[] result;
        }
        
        cout << successM << endl;
    }

    return 0;
}

本文地址:http://com.8s8s.com/it/it27006.htm