浙大在线评测 1045 hangover

类别:编程语言 点击:0 评论:0 推荐:
Question: 

    How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.

    The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

    For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.



Example input:

1.00
3.71
0.04
5.19
0.00



Example output:

3 card(s)
61 card(s)
1 card(s)
273 card(s)


Solution:

 // 声明:本代码仅供学习之用,请不要作为个人的成绩提交。
// http://blog.csdn.net/mskia
// email: [email protected]
#include <iostream.h>
#include <stdlib.h>

int main( void ) {
    float fz = 2.0;
    short int i;
    float   temp , n ;  
    while( cin >> n && n != 0 ) {
        fz = 2.0;
        temp = 0;
        i = 0;
    
        while ( temp <= n ) {
            ++i ;
            temp += 1 / fz ;
            ++fz;
        }
    
        cout << i << " card(s)" << endl;
     }

     return 0;
}

本文地址:http://com.8s8s.com/it/it27149.htm