浙大在线评测 1181 Word Amalgamation

类别:编程语言 点击:0 评论:0 推荐:
Problem:

    In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words.


Input:

    The input contains four parts:

    1. a dictionary, which consists of at least one and at most 100 words, one per line;
    2. a line containing XXXXXX, which signals the end of the dictionary;
    3. one or more scrambled `words' that you must unscramble, each on a line by itself; and
    4. another line containing XXXXXX, which signals the end of the file.

    All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique.


Output:

    For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line ``NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.


Sample Input:

tarp
given
score
refund
only
trap
work
earn
course
pepper
part
XXXXXX
resco
nfudre
aptr
sett
oresuc
XXXXXX


Sample Output:

score
******
refund
******
part
tarp
trap
******
NOT A VALID WORD
******
course
******


Solution:

#include <iostream>
#include <string>
#include <vector>
#include <set>
using namespace std;

// 声明:本代码仅供学习之用,请不要作为个人的成绩提交。
// http://blog.csdn.net/mskia
// email: [email protected]

int main( void ) {
    vector< string > dic;

    for ( ; ; ) {
        string word;
        cin >> word;
        if ( word == "XXXXXX" ) {
            break;
        }
       
        dic.push_back( word );
    }
   
    for ( ; ; ) {
        string word;
        cin >> word;
        if ( word == "XXXXXX" ) {
            break;
        }
       
        multiset< char > chars;
        for ( string::iterator p = word.begin( ); p != word.end( ); ++p ) {
            chars.insert( *p );
        }

        set< string > result;
        bool matched = false;
        for ( vector< string >::iterator dicp = dic.begin( ); dicp != dic.end( ); ++dicp ) {
            if ( word.length( ) == dicp->length( ) ) {
                multiset< char > temp( chars );
                for ( string::iterator strp = dicp->begin( ); strp != dicp->end( ); ++strp ) {
                    multiset< char >::iterator charp;
                    charp = temp.find( *strp );
                    if ( charp == temp.end( ) ) {
                        break;
                    }
                   
                    temp.erase( charp );
                }
               
                if ( temp.size( ) == 0 ) {
                    result.insert( *dicp );
                    matched = true;
                }
            }
        }
       
        if ( !matched ) {
            cout << "NOT A VALID WORD" << endl;
        } else {
            for ( set< string >::iterator p = result.begin( ); p != result.end( ); ++p ) {
                cout << *p << endl;
            }
        }
       
        cout << "******" << endl;
       
    }

    return 0;
}

本文地址:http://com.8s8s.com/it/it25847.htm